Routing Protocol Features and Commands
Route Protocol | Builds Topology Map | Router can independently
determine the shortest path to every network |
Convergence | A periodic/event driven routing updates | Use of LSP |
---|---|---|---|---|---|
Distance Vector | No | No | Slow | Generally no | No |
Link-state | Yes | Yes | Fast | Generally yes | Yes |
- Information taken from in-class presentation.
Name | Class | Type | Interior/Exterior | Default Metric | Administrative
Distance |
Hop Count Limit | Convergance | Classful/
Classless |
Update Timers | Updates | VLSM Support | Algorithm | Update Address | Protocol and Port |
---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|
RIPv1 | Distance Vector | IGP | Interior | Hopcount | 120 | 15 | Slow | Classful | 30 Seconds | Full Table | No | Bellman-Ford | Broadcast | UDP port 520 |
RIPv2 | Distance Vector | IGP | Interior | Hopcount | 120 | 15 | Slow | Classless | 30 Seconds | Full Table | Yes | Bellam-Ford | 224.0.0.9 | UDP port 520 |
IGRP | Distance Vector | IGP | Interior | Bandwidth/Delay | 100 | 255 (100 default) | Slow | Classful | 90 seconds | Full Table | No | Bellman-Ford | 224.0.0.10 | IP Protocol 9 |
EIGRP | Hybrid (Advanced Distance Vector) | IGP | Interior | Bandwidth/Delay | 90 (Internal)
170 (External) |
224 (100 default) | Very Fast | Classless | Only when change occurs | Only Changes | Yes | DUAL | 224.0.0.10 | IP Protocol port 88 |
OSPF | Link-state | IGP | Interior | Cost | 110 | None | Fast | Classless | Only when changes occur (LSA table is refreshed every 30 minutes, however) | Only Changes | Yes | Dijkstra (SPF) | 224.0.0.5 (All SPF Routers)
224.0.0.6 (DR's and DBR's) |
IP Protocol 89 |
IS-IS | Link-state | IGP | Interior | Cost | 115 | None | Fast | Classless | Only when changes occur | Only changes | Yes | Dijkstra (SPF) | N/A | N/A |
BGP | Path Vector | EGP | Exterior | Multiple Attributes | 20 (External)
200(Internal) |
EBGP Neighbors: 1 (Default)
IBGP Neighbors: None |
Average | Yes | Only when changes occur | Only changes | Yes | Best Path Algorithm | Unicast | TCP port 179 |
** Information condensed from http://www.routeralley.com/ra/docs/routing_protocol_comparison.pdf and http://globalconfig.net/ccna-corner/1147/
Commands for RIP
Router(config)#router rip - Enables RIP as a protocol
Router(config-router)#network w.x.y.z - w.x.y.z is the directly connected network you want to advertise
Router(config)#no router rip - Turns off RIP
Router(config-router)#no network w.x.y.z - Removes network
Router(config-router)#version 2 - Turns on V2 and now RIP will send and receive RIPv2 Packets
Router(config-router)#version 1 - RIP will send and receive RIPv1 Packets
Router(config-router)#no auto-summary - RipV2 summarizes networks at the classful boundary. This command will turns auto summary off
Router(config-router)#passive-interface s/0/0/1 - RIP updates will not be sent out this interface
Router(config-router)#neighbor a.b.c.d - Defines a specific neighbor to exchange information with
Router(config-router)#no ip split-horizon - Turns off split horizon (this is on by default)
Router(config-router)#ip split-horizon - Turns it back on
Router(config-router)#timers basic 30 60 90 180 270 360 - Changes timers in RIP: 30=Update timer, 90=Invalid Timer, 180=Hold down timer, 270= Flush timer, 360=Sleep timer
Router(config-router)#default-information originate - Generates a default route into RIP
** You can verify configurations by running the show commands at the Router# prompt ** Show ip protocol, show ip route, show ip interface brief
Commands for Troubleshooting
Router#debug ip rip - Displays all RIP activity in real time
Router#show ip rip database - Displays contents of the RIP database
Commands for EIGRP
Router(config)#router eigrp 100 - Enables EIGRP as a process. The number "100" is an autonomous system number (ASN) which can be any number between 1 and 65,535. All routers in the same system must use the same ASN
Router(config)#no router eigrp 100 - Removes EIGRP as a process.
Router(config-router)#network w.x.y.z - w.x.y.z is the directly connected network you want to advertise
Router(config-router)#no network w.x.y.z - Removes advertised network
Router(config-if)#bandwidth X - Sets the bandwidth of this interface to X kilobits to allow EIGRP to make the best metric calculation
Router(config-router)#network 1.1.1.1 0.0.0.3 - Tells which interface or network to include in EIGRP. Interfaces are configured with addresses that fall within the wildcard mask range of the network statement.
Router(config-router)#auto-summary - Enables auto summarization for the EIGRP process
Router(config-router)#no auto-summary - Turns the auto summarization feature of EIGRP off
** EIGRP automatically summarizes networks on the classful boundary ** If you have discontigous subnets you could have issues with connectivity if summarization is left on ** If turned off, it is recommended to use the ip summary-address command to summarize manually.
Router(config)#interface s0/0/0 - Enters interface configuration mode
Router(config-if)#bandwidth 256 - Sets the bandwidth of this interface
** You can verify configurations by running the show commands at the Router# prompt ** Show ip protocol, show ip route, sshow ip eigrp interfaces, show ip eigrp toploogy, show ip eigrp neighbors ** show ip eigrp neighbors detail, show ip eigrp traffic, show ip route eigrp
Commands for Troubleshooting
Router#debug eigrp fsm - Displays events and actions related to EIGRP feasible successor metrics (FSM)
Router#debug eigrp packet - Displays events and actions related to EIGRP packets
Router#debug eigrp neighbor - Displays events and actions related to EIGRP neighbors. Also debug ip eigrp neighbor
Router#debug eigrp packet - Displays events and actions related to EIGRP packets
Router#debug ip eigrp notifications - Displays EIGRP event notification
Commands for OSPF
Router(config)#router ospf 456 - Enables OSPF process. The number "456" is any positive number between 1 and 65, 535. It is not related to the OSPF area. The process ID is use to distinguish one process from another within the device. These numbers DO NOT have to match the process ID of an other router.
Router(config-router)#network 172.10.0.0 0.0.0.255 area 0 - OSPF advertises interfaces, not networks. It also uses the wildcard mask to determine whch interfaces to advertise. It is read as "any interface with the address of 172.10.0.0 is to be put in area 0.
Router(config-if)#ip address x.x.x.x x.x.x.x - Assigns IP address to interface
Router(config-router)#router-id 10.1.1.1 - Sets ID to 10.1.1.1 Takes affect at next reload.
Router(config-router)#no router-id 10..1.1.1 - Removes the static router ID from the configuration. Takes affect at next reload.
Router(config)#interface S0/0 - Changes interface to be configured
Router(config-if)#ip ospf priority 50 - Changes the OSPF interface priority to 50. The assigned priority can be between 0 and 255. The higher the number the higher the priority. A 255 guarantees a tie in the election for DR/BDR. Ties are broken by the highest router ID.
Router(config)#interface s0/0/0 - Changes to interface config mode
Router(config-if)#bandwidth 128 - If changed, OSPF will recalculate the cost of the link.
Router(config-if)#ip ospf hello-interval timer 20 - Changes the hello interval to 20 seconds
Router(config-if)#ip ospf dead-interval 80 - Changes the dead interval to 80 seconds
** Hello and Dead Timers must match for routers to become neighbors
Router(config)#ip route 0.0.0.0 0.0.0.0.0 s0/0 - Creates a default route
Router(config-router)#default-information originate - Sets the default route to be advertised to all OSPF routers
** You can verify configurations by running the show commands at the Router# prompt ** Show ip protocol, show ip route, show ip ospf, show ip ospf interface, show ip ospf border-routers, show ip ospf neighbor ** show ip ospf neighbor detail, show ip ospf database, show ip ospf database nssa-external
Commands for Troubleshooting
Router#clear ip route * - Clears entire table forcing it to rebuild
Router#clear ip route a.b.c.d - Clears specific route to network a.b.c.d
Router#clear ip ospf counters - Resets OSPF counters
Router#clear ip ospf process - Clears entire OSPF process forcing it to re-create neighbors, database, and routing table
Router#debug ip ospf events - Displays all OSPF events
Router#debug ip ospf adjacency - Displays various OSPF states and DR/BDR election between adjacent routers
Router#debug ip ospf packets - Displays OSPF packets
** ALL INFORMATION PROVIDED ON PAGE IS CONDENSED FROM "CCNA Portable Command Guide", by Scott Empson, cicsopress.com